Joomla: Database Error: Unable to connect to the database:Could not connect to MySQL
Joomla utilise une base de données. Si la connexion à la base de données échoue pour une raison ou une autre, vous pouvez recevoir ce message :
Database Error: Unable to connect to the database:Could not connect to MySQL
Dans le fichier configuration.php (situé dans le dossier où Joomla est installé), vous trouvez ces paramètres de connexion à la base de données :
var $host = 'localhost'; // C'est toujours localhost
var $user = 'XXX_ZZZ'; // XXX est le nom d'utilisateur du panneau de contrôle, ZZZ l'utilisateur de la base de données
var $db = 'XXX_YYY'; // XXX est le nom d'utilisateur du panneau de contrôle, YYY le nom de la base de données
var $password = 'motdepasse'; // Le mot de passe attribué à l'utilisateur de la base de données
Si la connexion échoue, il y a peut-être une erreur dans les données ci-dessus.
Connectez-vous au panneau de contrôle et choisissez le menu MySQL. Cliquez ensuite sur la base de données Joomla : les utilisateurs de la base de données s'affichent. Créez si besoin un nouvel utilisateur et saisissez son nom d'utilisateur et son mot de passe dans configuration.php. Si l'utilisateur existe déjà, modifiez son mot de passe par précaution pour qu'il corresponde à celui de configuration.php.
Si vous avez installé Joomla via Installatron, vous pouvez aussi retrouver le nom de la base de données via Installatron.
